[Libreoffice] build problems with cppunit

Regina Henschel rb.henschel at t-online.de
Tue May 31 10:24:36 PDT 2011

Hi Michael,

Michael Meeks schrieb:
> Hi Regina,
> On Mon, 2011-05-30 at 09:10 +0200, Regina Henschel wrote:
>> I have still problems building from tar source. Actual situation:
>> All modules folders are put into one root folder.
> 	That is odd; and/or annoying. If you want the best, most stable, and
> useful branch to hack on; I would personally recommend the:
> 	libreoffice-3-4
> 	tag in git - we can still get fixes included there, and it should
> compile and run on anything.
> 	Is there a reason for using the tars ? [ of course, they should work
> too - but - it is hard to isolate that the problem is not specific to
> them ].

It is the way I'm used to do in OOo. For OOo I would have to install 
something like TortoiseSVN, which slows down my computer noticeable. So 
I did not use it. I do not work fast, and trying to be "uptodate" all 
time, is impossible to me. I only build three or four times a year. I 
worked on a project often up to 3 month. When it was ready, I got the 
actual OOo version, transfered my solution to that version and generated 
the patch.

Actual I try to get a LO build to transfer and test my spline solutions, 
which work already in my DEV300m106 build.

> 	It looks like some nasty symbol visibility problem on Windows.
> 	Tor - any ideas ?

I have some further observation: I had tried a non-pro build. Today I 
have deleted the --enable-dbgutil switch and started a new build. Now it 
compiles xml2cmp without problems. Currently it is in hwpfilter. I can 
tell you tomorrow, whether building was successful. I do not use -P 
option to avoid any problems coming from parallelism, so compiling is slow.

Perhaps the problems have their reason in --enable-dbgutil ?

Kind regards

More information about the LibreOffice mailing list