[API] Some more cleanup ideas

Thorsten Behrens thb at documentfoundation.org
Mon Dec 3 01:39:44 PST 2012

Jan Holesovsky wrote:
> Please _please_ PLEASE name it "api" as you proposed first, not "css" -
> it nearly killed me when I found out what that means when I started with
> OOo [that it is not "cascade style sheet", but "com::sun::star"] - think
> of the newcomers ;-)
Well, that needs some amount of explanation, too, since the nested
namespace is still there, and needs to be used when implementing an
interface. Personally I like api slightly better, but I simply lack
the time today. If someone signs up for that, then let's please also
change _all_ occurences of css in implementation code, _and_ the SDK


-- Thorsten
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 198 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/libreoffice/attachments/20121203/20343459/attachment.pgp>

More information about the LibreOffice mailing list