[API] Some more cleanup ideas

Michael Meeks michael.meeks at suse.com
Mon Dec 3 02:00:38 PST 2012

On Mon, 2012-12-03 at 10:39 +0100, Thorsten Behrens wrote:
> Jan Holesovsky wrote:
> > Please _please_ PLEASE name it "api" as you proposed first, not "css" -
> > it nearly killed me when I found out what that means when I started with
> > OOo [that it is not "cascade style sheet", but "com::sun::star"] - think
> > of the newcomers ;-)
> Well, that needs some amount of explanation, too, since the nested
> namespace is still there, and needs to be used when implementing an
> interface.

	Well - IMHO it's far easier to explain 'api' on an ongoing basis than
'com::sun::star::' truncated to 'css' ;-)

>  Personally I like api slightly better, but I simply lack
> the time today. If someone signs up for that, then let's please also
> change _all_ occurences of css in implementation code, _and_ the SDK
> examples.

	Sounds reasonable to me.



michael.meeks at suse.com  <><, Pseudo Engineer, itinerant idiot

More information about the LibreOffice mailing list