Minimum Perl version requirement (was: Re: [PUSHED] Replace make_absolute_path with rel2abs in solenv)

Tim Retout tim at
Mon Feb 20 05:47:17 PST 2012

On 20 February 2012 11:30, Michael Meeks <michael.meeks at> wrote:
> On Sun, 2012-02-19 at 14:39 +0000, Tim Retout wrote:
>        Great :-) thanks for that, it's always nice to use standard methods
> instead of custom / hand-coded ones. Clearly we want to introduce new
> perl dependencies on shared modules only with some care - it's nice
> having solenv/ be reasonably self-contained.

Indeed - a useful tool is 'corelist', which will print the first
version of Perl which shipped a given CPAN module in the core:

    $ corelist File::Spec

    File::Spec was first released with perl 5.00405

(i.e. Perl 5.4)

Which leads to the question: what is the minimum version of Perl we
can rely on in LibreOffice?  Currently checks for Perl 5,
but the Perl currently in solenv almost certainly requires Perl 5.8
(first released 2002).

Even Perl 5.10 (first released 2007) is no longer maintained upstream,
although it is still the one shipped in Debian squeeze/lenny (current

Would it be reasonable to bump the check to look for Perl
5.10, for now?  I might try to replace the macro with one from the
autoconf archive:;a=blob_plain;f=m4/ax_prog_perl_version.m4

Kind regards,

Tim Retout <tim at>

More information about the LibreOffice mailing list