Trying to build on Windows, multiple target patterns

Jeremy Brown jeremy.r.brown at
Wed Oct 17 05:14:47 PDT 2012

OK, thanks everyone for the various suggestions.

(I was already using the patched LibreOffice make but it was worth checking.)

I'm attaching the contents of iacc.lib.d:948
I was also sometimes getting the same error for ianimcore.lib.d:1:

I enabled the --disable-dependency-tracking option, and running make
again I then got error dialogs stating:

Microsoft Visual C++ Runtime Library
Runtime Error!
Program: D:\Dev\l...
An application has made an attempt to load the C runtime library incorrectly.
Please contact the application's support team for more information.

The errors in the build were:
Failed to load dynamic library: ...

for the following tests

The make process recommends:
Error: a unit test failed, please do one of:
export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking

Are there any recommendations on which one I should try?

Is there anything else I should try to resolve the errors about dlls
failing to load?

(I'm also going through the wiki page Flavio linked to and trying to
make sure my Cygwin environment matches what he has, but I haven't
finished going through the list yet. I was using a Cygwin package set
based on what is at,
but that has less packages that Flavio listed.)



On Tue, Oct 16, 2012 at 7:48 AM, Matúš Kukan <matus.kukan at> wrote:
>> My current problem is that I run make and it runs for a while and then
>> dies in tail_build with an error like this:
>> D:/Dev/libo/libo/workdir/
>> *** multiple target patterns. Stop.
> Oh, this one is probably new, related to
> changes in solenv/bin/concat-deps.c :
> What is in D:/Dev/libo/libo/workdir/
> ?
-------------- next part --------------
A non-text attachment was scrubbed...
Name: iacc.lib.d
Type: application/octet-stream
Size: 8667 bytes
Desc: not available
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: ianimcore.lib.d
Type: application/octet-stream
Size: 24730 bytes
Desc: not available
URL: <>

More information about the LibreOffice mailing list