'test-bugzilla-files.py' issues

John Smith lbalbalba at gmail.com
Tue Apr 15 01:23:14 PDT 2014


I seem to have some issues starting and/or connecting to soffice in
headless mode.

When i run 'soffice.bin
--quickstart=no --nofirststartwizard --norestore --nologo --headless

'lsof' shows the soffice pipe is created successfully.

But when I run 'dev-tools/test-bugzilla-files.py
/usr/local/src/libreofficedocs/', the connection fails.

The same thing happens when i use sockets instead of named pipes.
This listens on a socket: soffice --headless --invisible --nologo
--norestore "--accept=socket,port=8100"
But this doesnt:  python dev-tools/test-bugzilla-files.py
--soffice=connect:socket,port=8100 /usr/local/src/libreofficedocs/

'dev-tools/test-bugzilla-files.py' basically does the same thing as
what i do on the command line. If anyone has an idea of what could be
going wrong, or where to start troubleshooting, any and all help is



John Smith.

More information about the LibreOffice mailing list