'test-bugzilla-files.py' issues

Stephan Bergmann sbergman at redhat.com
Tue Apr 15 03:57:25 PDT 2014

On 04/15/2014 10:23 AM, John Smith wrote:
> I seem to have some issues starting and/or connecting to soffice in
> headless mode.
> When i run 'soffice.bin
> -env:UserInstallation=file:///tmp/.config/libreoffice/4
> --accept="pipe,name=pytest50f337fa-c471-11e3-93ba-000c29d3eeee;urp"
> --quickstart=no --nofirststartwizard --norestore --nologo --headless
> --nodefault'
> 'lsof' shows the soffice pipe is created successfully.
> But when I run 'dev-tools/test-bugzilla-files.py
> --soffice=path:/usr/local/src/libreoffice/instdir/program/soffice
> --userdir=file:///tmp/.config/libreoffice/4
> /usr/local/src/libreofficedocs/', the connection fails.
> The same thing happens when i use sockets instead of named pipes.
> This listens on a socket: soffice --headless --invisible --nologo
> --norestore "--accept=socket,port=8100"
> But this doesnt:  python dev-tools/test-bugzilla-files.py
> --soffice=connect:socket,port=8100 /usr/local/src/libreofficedocs/
> 'dev-tools/test-bugzilla-files.py' basically does the same thing as
> what i do on the command line. If anyone has an idea of what could be
> going wrong, or where to start troubleshooting, any and all help is
> appreciated.

I cannot reproduce your problems here on recent master.  Try to strip 
down the dev-tools/test-bugzilla-files.py side as much as possible to 
see why it fails to connect.

Some more notes:

* Never start soffice.bin directly, always use soffice instead.

* At least in current gerrit.libreoffice.org/dev-tools there is no 
dev-tools/test-bugzilla-files.py, but only non-executable 
dev-tools/test-bugzilla-files/test-bugzilla-files.py that you need to 
run as "/usr/local/src/libreoffice/instdir/program/python 
dev-tools/test-bugzilla-files/test-bugzilla-files.py ..."


More information about the LibreOffice mailing list