Building LibreOffice on OS X problem

Christian Lohmaier lohmaier at
Thu Sep 15 13:23:17 UTC 2016

Hi Michael, *,

On Mon, Sep 12, 2016 at 10:07 PM, Michael Lewis <m1ewi5 at> wrote:
> I hope I’m going to the right place with this question. I followed the
> directions for “Building LibreOffice on OS X” (Minimal Setup)

Apparently you did not..

> There is a warning on this web page: When building LibreOffice on OS X
> 10.11, you currently need to use at least --disable-firebird-sdbc. I did not
> know where to insert this code, so I did not use it.

you're supposed to use this as one of the flags to pass to
./, either by adding it to the commandline itself or by
putting it into autogen.input

> I got most of the way through the build instructions. But at Step 12 (Build
> LibreOffice), I executed the ./ call and got the following error:
> Failed to run aclocal at ./ line 171.
> Line 171 contains
> system (“$aclocal $aclocal_flags”) && die "Failed to run aclocal";

either you missed step 9 (compiling autoconf) or you did not add the
installation directory to your PATH environment variable.

> I shut my system down and restarted. Same error, even when I run as su.

Don't run as root/don't use su, this is not necessary.
But actually follow the minimal steps listed on the page, especially
adding the path to the dependencies to your PATH environment variable.

the instructions use /opt/lo as prefix (but you can use
/Users/someuser/whatever/directory), so you would have to add
/opt/lo/bin to your PATH environment variable, so the shell can find
the commands.

so take special care about point 7 in the minimal instructions.

It is *NOT* ok to skip steps/ignore the results that you're told to
check and then expect the build to work...


More information about the LibreOffice mailing list