Building LibreOffice on OS X problem

Jan Iversen jani at
Tue Sep 13 09:50:47 UTC 2016

> On 12 Sep 2016, at 22:07, Michael Lewis <m1ewi5 at> wrote:
> I hope I’m going to the right place with this question. I followed the directions for “Building LibreOffice on OS X” (Minimal Setup) <>.
> There is a warning on this web page: When building LibreOffice on OS X 10.11, you currently need to use at least --disable-firebird-sdbc. I did not know where to insert this code, so I did not use it.
you need to add (or create) that in a file called “autogen.input” that file is placed in the root of your repo.

> I got most of the way through the build instructions. But at Step 12 (Build LibreOffice), I executed the ./ call and got the following error: Failed to run aclocal at ./ line 171.
> Line 171 contains
> system (“$aclocal $aclocal_flags”) && die "Failed to run aclocal”;
Could it be that you did not install the libreoffice dependencies ?

at least on my new mac, aclocal was not preinstalled.

I did use
since it was easier, and how just build / start LO without problems.

I can suggest you take a look at:

that might help you with many of the aspects.

jan I.

> I don’t know how to fix the problem with the alocal call. I am running Xcode 7.3.1 under OSX 10.11.6. Xcode seems to run OK, although I’m a new user (and brand new to LO development).
> I shut my system down and restarted. Same error, even when I run as su.
> Any advice appreciated. Thanks, ML
> _______________________________________________
> LibreOffice mailing list
> LibreOffice at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the LibreOffice mailing list