Libreoffice 6.1 branch fails to build against >=harfbuzz-1.8.1

George Diamantopoulos georgediam at
Mon Jul 9 16:25:40 UTC 2018

Hello all,

I've been trying to build the current 6.1 git branch of libreoffice,
and it seems that it has trouble finding some headers provided by
harfbuzz. More specifically, compilation fails with:

> libreoffice-6.1.9999/vcl/inc/sallayout.hxx:28:10: fatal error: hb.h: No such file or directory

This is on gentoo, using the ebuild found in portage. I opened a bug
on gentoo's bugzilla first, but I was told by a developer there that I
should notify upstream. I checked for presence of the header file on
my system, and it's available in the following path:

> /usr/include/harfbuzz/hb.h

You may find a build log and environment information at the
aforementioned gentoo bug page:


Please let me know if I can be of further help. I've tried with
harfbuzz 1.8.1 and 1.8.2, same result. I'm not sure if 1.8.0 is
affected as well. Reportedly, libreoffice 6.0 builds fine with these
library versions (not tested by me, other users said so in the gentoo
bug page). Thank you.

Best regards,

More information about the LibreOffice mailing list