Calc and auto-corrupt (again)

Wols Lists antlists at
Mon Sep 16 13:58:59 UTC 2019

I guess this is something to do with the input engine, but I had some
fun with formulae yesterday, using LO on SUSE (so a pretty recent
version). I tried to reproduce it on my old gentoo system so somewhat
out of date, and got similar but different results.

Put some data in a couple of cells, then compare them with the following


Note the mistakes, I forgot the equals, there's a dot instead of a
comma, and there are two closing brackets. Now try and correct it!

On the ancient version of LO, auto-corrupt gives me


in other words, the "true" and "false" parts just disappeared. I tried
it several times, so it's not me being fat-fingered ...

On SUSE, I got

=if(a3>a4, the recent LO,"Lower","Higher"))

ie I just could NOT get rid of the trailing bracket! Again, I tried
repeatedly and unsuccessfully. Can we add this to the group of input
frustrations in calc where it won't do what the user tells it to do?

On a different note in the same place, the formula tooltip was a pain in
the neck - it placed itself half over the input box which is all very
well if you're entering a new formula, but if you're trying to correct
an existing formula, it's obscuring what you're trying to correct!


More information about the LibreOffice mailing list