First-time build error

Alan Frank alan at
Tue Mar 2 01:15:05 UTC 2021

Thanks--that did the trick.

-------- Original Message --------
Subject: Re: First-time build error
Date: 25.02.2021 22:53
 From: W T <winstontjong at>
To: Alan Frank <alan at>

Hi Alan,

I'm relatively new as well and had the same problem a few weeks ago.
In my case, Al.exe is part of .NET Framework 4.8 SDK.
So I solved the problem by going back to the Visual Studio Installer
and modifying the installation
to include .NET Framework 4.8 SDK.  I chose this because it was the
latest version available on my installer.
Also, be sure to include Windows Universal C Runtime.

I found out that when I chose "Desktop development with C++" workload,
.NET Framework 4.8 SDK
and Windows Universal C Runtime were not included. You can go to the
"Individual components" tab in
the "Modifying" window and select them manually.

Hope this helps.

Winston Tjong

On Thu, Feb 25, 2021 at 5:53 PM Alan Frank <alan at> wrote:

> I am a new developer, trying to get started.  Ilmari provided a
> bunch of
> resources; I installed lots of software and got to the point where I
> thought I was ready to build.  I entered the command and options
> from
> the instructions:
> /cygdrive/c/sources/libo-core
> $   /cygdrive/c/sources/libo-core/ \
> --with-external-tar=/cygdrive/c/sources/lo-externalsrc \
> --with-junit=/cygdrive/c/sources/junit-4.10.jar \
> --with-ant-home=/cygdrive/c/sources/apache-ant-1.9.5
> \
> --enable-pch --disable-ccache
> After lots of successful assertions, I ran into this error:
> checking for al.exe... configure: error: al.exe not found as /al.exe
> Error running configure at /cygdrive/c/sources/libo-core/
> line
> 316.
> Line 316: system ("./configure", @args) && die "Error running
> configure";
> The file al.exe does not exist anywhere on my machine.  A web search
> suggests that it comes with the MS Visual Studio install and lives
> in
> C:\Windows\Microsoft.NET\Framework\v2.0.50727 (even though there are
> also folders for v3.0, v3.5, and v4.0.30319).  I did that as part of
> my
> install, and the directory has 185 files, but no al.exe.  I was not
> able
> to find any trustworthy place to just download al.exe.
> --Alan
> _______________________________________________
> LibreOffice mailing list
> LibreOffice at

More information about the LibreOffice mailing list