[Mesa-dev] [PATCH 6/6] translate_sse: major rewrite

Luca Barbieri luca at luca-barbieri.com
Fri Aug 13 04:46:43 PDT 2010

> Is it possible to use an explicit flag for the (out_chans == 5) case?

Gave it the name CHANNELS_0001 and added a comment.

> Is it possible to do this without all the #ifdefs?  Even if statements
> based on a preprocessor variable would be easier to read, but better
> still would be some sort of wrapper function which just did the right
> thing on either architecture.

Right, done.

> Similar comment applies to your x86-64 changes in rtasm.c -- is there a
> way to reduce the #ifdef load?

Here it seems impossible, as it doesn't seem to be possible to
abstract any of them (except possibly adding a function to encode both
INC and DEC , but that doesn't really seem a win).

> +            // TODO: add support for SSE4.1 pmovzx
> Probably want to use C-style comments throughout.


More information about the mesa-dev mailing list