[Mesa-dev] [PATCH 6/6] translate_sse: major rewrite

Keith Whitwell keithw at vmware.com
Fri Aug 13 05:24:39 PDT 2010

On Fri, 2010-08-13 at 04:46 -0700, Luca Barbieri wrote:
> > Is it possible to use an explicit flag for the (out_chans == 5) case?
> Gave it the name CHANNELS_0001 and added a comment.
> > Is it possible to do this without all the #ifdefs?  Even if statements
> > based on a preprocessor variable would be easier to read, but better
> > still would be some sort of wrapper function which just did the right
> > thing on either architecture.
> Right, done.
> > Similar comment applies to your x86-64 changes in rtasm.c -- is there a
> > way to reduce the #ifdef load?
> Here it seems impossible, as it doesn't seem to be possible to
> abstract any of them (except possibly adding a function to encode both
> INC and DEC , but that doesn't really seem a win).

What about just making things prettier by converting the #if's into
regular if statements?  It would be easier to read if nothing else,
though it would mean compiling at least a stub version of the x86-64
opcode emitters on x86.

In fact there's nothing preventing us compiling the entire x86-64
emitters on x86, though obviously they can't be used -- but there's
nothing which requires that code to be #ifdef'ed out on other platforms.


More information about the mesa-dev mailing list