[Mesa-dev] [PATCH 02/10] mesa: add ARB_tessellation_shader boolean and constants
zackr at vmware.com
Mon Sep 6 15:17:30 PDT 2010
On Monday 06 September 2010 11:25:31 Luca Barbieri wrote:
> On Mon, Sep 6, 2010 at 4:45 PM, Zack Rusin <zackr at vmware.com> wrote:
> > Maybe lets skip this and other tessellation patches until we have code
> > that actually does something. It's just going to be confusing to have
> > not finished (or really "not started" =) ) code that doesn't do
> > anything.
> The idea is that having it will prevent writing code that naively
> assumes there are only 2 or 3 shader types.
It'd be hard to argue with that given that this is how many we support.
Everything but GEOMETRY, VERTEX and FRAGMENT should assert because we just
don't support it.
> > Also in terms of naming, I severely dislike abbreviations because code
> > tends to be written once but debugged hundred of times so optimizing for
> > readability makes long term sense, i.e.
> > PIPE_SHADER_TESSELLATION_EVALUATION (or at least
> > PIPE_SHADER_TESS_EVALUATION to match the GL spec) instead TESSEVAL. and
> > such.
> Yes, this is debatable.
Nah, it really isn't. We use full names for shaders and we are (or at least
are trying to) be consistent in the interface naming. All identifiers that
don't follow the naming scheme and are inconsistent with the rest are bad. The
only question is whether it's TESS because of the fact that GL calls it that
or whether it's full TESSELLATION because that's what it really is.
More information about the mesa-dev