[Mesa-dev] [PATCH 02/10] mesa: add ARB_tessellation_shader boolean and constants

Luca Barbieri luca at luca-barbieri.com
Mon Sep 6 08:25:31 PDT 2010

On Mon, Sep 6, 2010 at 4:45 PM, Zack Rusin <zackr at vmware.com> wrote:
> Maybe lets skip this and other tessellation patches until we have code that
> actually does something. It's just going to be confusing to have not finished
> (or really "not started" =) ) code that doesn't do anything.

The idea is that having it will prevent writing code that naively
assumes there are only 2 or 3 shader types.

> Also in terms of naming, I severely dislike abbreviations because code tends
> to be written once but debugged hundred of times so optimizing for readability
> makes long term sense, i.e. PIPE_SHADER_TESSELLATION_EVALUATION (or at least
> PIPE_SHADER_TESS_EVALUATION to match the GL spec) instead TESSEVAL. and such.

Yes, this is debatable.
Since the names of the other shader stages are short, it seemed
aesthetically better to make those short too.

More information about the mesa-dev mailing list