[Mesa-dev] [Bug 39515] New: FTBFS: libEGL depends on libgbm, but libEGL builds first

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Jul 24 17:37:36 PDT 2011


           Summary: FTBFS: libEGL depends on libgbm, but libEGL builds
           Product: Mesa
           Version: git
          Platform: x86-64 (AMD64)
        OS/Version: Linux (All)
            Status: NEW
          Severity: normal
          Priority: medium
         Component: Other
        AssignedTo: mesa-dev at lists.freedesktop.org
        ReportedBy: dawitbro at sbcglobal.net

Created an attachment (id=49481)
 --> (https://bugs.freedesktop.org/attachment.cgi?id=49481)
full build output demonstrating dependency error

I am trying to update my old build system to produce DEB packages for Debian
Sid.  The last build from git I tried was May 2 (commit eb0a9e9a).  Much has
changed since then, and I found that I needed to update my debian/rules and add
some new *.install files, etc.  (Up until that time, my builds worked fine for
over a year.)

I had made an archive from git on July 18, but didn't get around to working
with it until today.  After making adjustments for the changed 'configure'
options and the new 'libgbm' library, among other things, I found that my build
failed reproducibly when trying to make libEGL:

    /bin/bash ../../../bin/mklib -o EGL -linker 'gcc' -ldflags '' \
                -major 1 -minor 0 \
                -install ../../../x86_64-linux-gnu  \
                -L../../../x86_64-linux-gnu  -ldl  -lpthread -lX11-xcb -lX11 \
                -lxcb-dri2 -lxcb-xfixes -lxcb-render -lxcb-shape -lxcb \
                -lgbm -ludev -lrt   -ldl -ldrm    -lX11   -ldl \
                eglapi.o eglarray.o eglconfig.o eglcontext.o eglcurrent.o \
                egldisplay.o egldriver.o eglfallbacks.o eglglobals.o \
                eglimage.o egllog.o eglmisc.o eglmode.o eglscreen.o \
                eglstring.o eglsurface.o eglsync.o \
                ../../../src/egl/drivers/dri2/libegl_dri2.a \
    mklib: Making Linux shared library:  libEGL.so.1.0
    /usr/bin/ld: cannot find -lgbm
    collect2: ld returned 1 exit status
    mklib: Installing libEGL.so.1.0 libEGL.so.1 libEGL.so in \
    mv: cannot stat `libEGL.so.1.0': No such file or directory
    make[4]: Leaving directory `/home/dawitbro/sandbox/xorg-local/mesa/

Later in the build this can be seen:

    /bin/bash ../../../bin/mklib -o gbm -linker 'gcc' -ldflags '' \
                -major 1 -minor 0 \
                -install ../../../x86_64-linux-gnu  \
                -L../../../x86_64-linux-gnu  -ldl -ludev -lrt   \
                gbm.o backend.o common.o  ../../../src/gbm/backends \
    mklib: Making Linux shared library:  libgbm.so.1.0
    mklib: Installing libgbm.so.1.0 libgbm.so.1 libgbm.so in 
    make[4]: Leaving directory `/home/dawitbro/sandbox/xorg-local/mesa/

This looks like a dependency problem, but my skill set is insufficient for
trying to solve the problem and submitting a patch.  It could also be a problem
with the set of options I have selected; I am only a user, not a developer, so
I could easily be the weakest link in the chain here.

Hoping that it is a problem that was addressed since July 18, I did a fresh git
pull and tried again.  Same failure.  I am attaching the full output from my
attempt to build from the latest version I have:  7.12-devel (July 24) at
commit 4d23c6df.  This output (obviously) shows the options used and the
commands that were run.

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list