[Mesa-dev] [PATCH] glsl: Add gl_MaxVaryingComponents in GLSL 1.30.
Kenneth Graunke
kenneth at whitecape.org
Sun Oct 23 13:49:57 PDT 2011
On 10/23/2011 12:49 AM, Eric Anholt wrote:
> This is the new name for gl_MaxVaryingFloats now that non-float
> varyings exist. Fixes piglit
> glsl-1.30/execution/maximums/gl_MaxVaryingFloats
> ---
> src/glsl/ir_variable.cpp | 2 ++
> 1 files changed, 2 insertions(+), 0 deletions(-)
>
> diff --git a/src/glsl/ir_variable.cpp b/src/glsl/ir_variable.cpp
> index 720bcc6..1ee84d2 100644
> --- a/src/glsl/ir_variable.cpp
> +++ b/src/glsl/ir_variable.cpp
> @@ -615,6 +615,8 @@ generate_130_uniforms(exec_list *instructions,
>
> add_builtin_constant(instructions, symtab, "gl_MaxClipDistances",
> state->Const.MaxClipPlanes);
> + add_builtin_constant(instructions, symtab, "gl_MaxVaryingComponents",
> + state->Const.MaxVaryingFloats);
> }
Reviewed-by: Kenneth Graunke <kenneth at whitecape.org>
More information about the mesa-dev
mailing list