[Mesa-dev] [Bug 45571] fatal error: program/symbol_table.h: No such file or directory

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Feb 4 13:00:38 PST 2012


--- Comment #6 from Matt Turner <mattst88 at gmail.com> 2012-02-04 21:00:38 UTC ---
(In reply to comment #4)
> If it is necessary to run "git clean -dfx" after every change
> to mesa that means nothing but that the build system is broken
> and should be fixed.

How do you expect `make clean` (ie, the build system) to know to clean files
that have been removed from git?

(In reply to comment #5)
> (In reply to comment #2)
> > You should run `git clean -dfx` and rerun autogen.sh after changes to Mesa.
> I run into this error too.
> Running git clean -dfx doesn't solve this issue.
> Installing a new mesa clone still shows this compilation error.
> Building mesa-8.0-rc2 too does not work, the compilation ends with the
> same error.

Huh. If you can reproduce it with Mesa-8.0-rc then I'm off the hook. :)

(I cannot reproduce the problem.)

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list