[Mesa-dev] [Bug 45571] fatal error: program/symbol_table.h: No such file or directory

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Feb 4 21:07:34 PST 2012


--- Comment #7 from Alexandre Demers <alexandre.f.demers at gmail.com> 2012-02-04 21:07:34 PST ---
I tried using "git clean -dfx" as suggested, which means I run both git clean
-dfx and make realclean. The build ends up with an error anyway. However, the
error is not the same:

In file included from ../../src/mesa/main/api_exec_es2_remap_helper.h:29:0,
                 from main/api_exec_es2.c:2222:
../../src/mesa/main/remap.h:34:1: error: expected ‘)’ before ‘struct’

I'm building with "make -j", but if I just run "make" after that error to retry
where it exited, I'm able to finish the build. So there still is a problem with
the build. I tried building without "-j" from the start and it ends up
correctly on the first run.

About what I'm experiencing, I think I'm now dealing with a different bug.
However, it seems the original problem shouldn't occure in the first place and
we should find why files are not generated as they should if they are different
from the ones already available. Finally, one of us seems to be experiencing
the same problem, but the proposed solution doesn't work, so I think we should
also ask ourselves why. What should be the next step to dig deeper?

Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

More information about the mesa-dev mailing list