[Mesa-dev] [PATCH] r600g: add htile support v8

Andy Furniss andyqos at ukfsn.org
Sun Jul 15 13:20:02 PDT 2012

Marek Olšák wrote:
> On Sun, Jul 15, 2012 at 12:57 PM, Andy Furniss <andyqos at ukfsn.org> wrote:
>> Marek Olšák wrote:
>>> FYI, I have pushed your DB decompression fix, because my
>>> not-yet-published work depends on it.
>> I can't be sure whether todays changes caused this, because I can't
>> reproduce it :-(
>> But I haven't seen it before and didn't see it 24hrs ago when I ran the same
>> test.
>> Today I updated mesa and did my normal nexuiz timedemo demo1 then ran an
>> etqw timenetdemo and after a while the scene started getting some flashing
>> corruptions and then it bailed with the below.
>> This is on an hd4890 with r600 llvm enabled, as I say I can't reproduce, if
>> I find a way I'll file a bug/bisect - but it's not looking like I will.
>> r600_pipe.h:708:r600_write_context_reg_seq: Assertion `cs->cdw+2+num <= (16
>> * 1024)' failed.
> I've pushed a commit (bc6bff79475ab0996923a105fa699a19fb65455e) that
> should hopefully fix this issue.

Seems to have fixed it - I just left it running for an hour without issue.

Previously 25 mins was the longest needed to trigger.

More information about the mesa-dev mailing list