[Mesa-dev] Very low framerate when recording desktop content in Weston using mesa git on Radeon 5770 (glReadPixels slow path)

Rune Kjær Svendsen runesvend at gmail.com
Sun Mar 17 10:26:54 PDT 2013

Hello list

I'm having problems recording the desktop content using the Weston
compositor's built-in recording function. When I start a recording and do
something that changes a lot of screen content (like zooming in on the
desktop, for example), I get around 0.5 FPS. Using sysprof, I can see that
~98% of CPU is used in the function unpack_XRGB8888(). krh has told me this
is caused by glReadPixels going through a slowpath. I have a Radeon HD 5770
GPU and I'm using mesa git (I've tried the mesa version in the Ubuntu 12.10
repos, and the xorg-edgers PPA, same result).

Does anyone know what the issue could be, or how to debug the problem

Doing some debugging, it seems the call to ctx->Driver.ReadPixels()
in _mesa_ReadnPixelsARB leads to _mesa_readpixels() being called in

I'm attaching some output of gdb that will hopefully be useful.

I'm also attaching the debug terminal output of running Weston with the DRM

Let me know if I can provide other useful information.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20130317/83eb37f0/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: weston-mesa.log
Type: application/octet-stream
Size: 8534 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20130317/83eb37f0/attachment-0002.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: gdb-mesa.log
Type: application/octet-stream
Size: 14543 bytes
Desc: not available
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20130317/83eb37f0/attachment-0003.obj>

More information about the mesa-dev mailing list