[Mesa-dev] Very low framerate when recording desktop content in Weston using mesa git on Radeon 5770 (glReadPixels slow path)

Andreas Boll andreas.boll.dev at gmail.com
Sun Mar 17 10:46:15 PDT 2013

2013/3/17 Rune Kjær Svendsen <runesvend at gmail.com>:
> Hello list
> I'm having problems recording the desktop content using the Weston
> compositor's built-in recording function. When I start a recording and do
> something that changes a lot of screen content (like zooming in on the
> desktop, for example), I get around 0.5 FPS. Using sysprof, I can see that
> ~98% of CPU is used in the function unpack_XRGB8888(). krh has told me this
> is caused by glReadPixels going through a slowpath. I have a Radeon HD 5770
> GPU and I'm using mesa git (I've tried the mesa version in the Ubuntu 12.10
> repos, and the xorg-edgers PPA, same result).
> Does anyone know what the issue could be, or how to debug the problem
> further?

This patch series [1] should help. You might want to try it.

[1] http://lists.freedesktop.org/archives/mesa-dev/2013-March/036214.html

> Doing some debugging, it seems the call to ctx->Driver.ReadPixels() in
> _mesa_ReadnPixelsARB leads to _mesa_readpixels() being called in readpix.c.
> I'm attaching some output of gdb that will hopefully be useful.
> I'm also attaching the debug terminal output of running Weston with the DRM
> backend.
> Let me know if I can provide other useful information.
> _______________________________________________
> mesa-dev mailing list
> mesa-dev at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/mesa-dev

More information about the mesa-dev mailing list