[Mesa-dev] OpenGL ES 3.0 support

Jordan Justen jljusten at gmail.com
Mon Mar 25 09:59:33 PDT 2013

On Mon, Mar 25, 2013 at 9:41 AM, violin yanev <violin.yanev at gmail.com> wrote:
> Hello,
> I was eager to try the OpenGL ES 3.0 support on the newest Mesa 9.1.
> I installed the latest Fedora Rawhide on my Sandy Bridge.

I believe this Fedora commit which disabled GL3 for Intel graphics
will also disable GLES3 for Intel graphics:


> I think the
> graphics chip is HD 2000, lspci says I have a Xeon E3-1200 V2/3rd gen
> processor. glxinfo states that I have Mesa 9.1, and lsmod lists i915 as my
> VGA driver, so it seems that the setup is right. I wrote a simple EGL
> program (used the opengles2 example as basis) and tried to create am OpenGL
> ES3 context. I tried two methods:
> 1) Giving a value of 3 in the API version eglChooseConfig
> This had the result that no matching configs were found.
> 2) Supplying the EGL_OPENGL_ES3_BIT_KHR flag in eglCreateContext (the
> EGL_KHR_create_context extension is present). This didn't work either
> (eglCreateContext returns an error).
> I am probably doing it the wrong way, but I didn't find any information on
> the internet on how to try the ES3.0 support (I checked the mesa-users
> mailing list, the mesa news, the intel linux drivers webpage, and even
> searched the commit history of mesa...). I would really appreciate some
> help!
> _______________________________________________
> mesa-dev mailing list
> mesa-dev at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/mesa-dev

More information about the mesa-dev mailing list