[Mesa-dev] [Bug 81785] MESA checks on configure for llvm 3.4.2 and fails to build with 3.4.2 being installed

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sun Jul 27 13:59:10 PDT 2014


--- Comment #10 from darkvision at gmx.eu ---
I was using llvm cmake until MESA 10.2 and had no problems with
REQUIRES_RTTI=1, worked very well. The only module that failed after upgrading
from 10.0.x to 10.2.x was xa, which complains about missing def like
llvm::format_object_base. When using latest MESA git another miss was
llvm::JITMemoryManager. I tried --disable-xa and everything was OK. After
switching to configure MESA 10.2.4 builds fine, even with xa enabled.

In reply to comment #9:
I'm compiling on Slackware linux. -current has LLVM 3.4.2 and MESA 10.2.4 in
the tree (sources in subdir d and x). The slackbuild script for LLVM uses
configure. The libdir locations can be found there. You also need a patch for
removing rpath data if you take care about that (works better on the cmake

You are receiving this mail because:
You are the assignee for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20140727/3d90ae32/attachment.html>

More information about the mesa-dev mailing list