[Mesa-dev] clEnqueueNDRangeKerne return error -52 with off-line compiled kernel

Vincent DEDIEU vincent.dedieu at axel.com
Fri Oct 17 08:34:40 PDT 2014



I compiled the very last mesa package (V10.4.0-devel) on Ubuntu-14.04 with


On a test program when I used clCreateProgramWithSource() and
clBuildProgram(), my kernel works perfectly.


But when I tried to use an already compiled kernel with
clCreateProgramWithBinary(), I get an error -52 later with


Of course I tried a very simple kernel such as:


void pi(__global float * out)


  out[0] = 3.14159f;



The kernel is compiled with clCreateProgramWithSource() and
clBuildProgram(). And the binary is stored in a file with


Anybody experienced this?


Note: if I used binary llvm/libclc/mesa packages (instead of compiling all
of them) my test program works fine.


Thank you



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/mesa-dev/attachments/20141017/bd3407b8/attachment.html>

More information about the mesa-dev mailing list