[Mesa-dev] [PULL] i965: rename brw_gs -> brw_ff_gs; rename brw_vec4_gs -> brw_gs.

Iago Toral itoral at igalia.com
Wed Oct 29 06:06:13 PDT 2014

On Tue, 2014-10-28 at 19:27 -0700, Kenneth Graunke wrote:
> Hello,
> I'd like to rename some files in i965:
> - brw_gs.c      -> brw_ff_gs.c
> - brw_gs.h      -> brw_ff_gs.h
> - brw_gs_emit.c -> brw_ff_gs_emit.c
> - brw_vec4_gs.c -> brw_gs.c
> - brw_vec4_gs.h -> brw_gs.h
> The current "brw_gs" files are about emulating fixed-function functionality 
> (VF primitive decomposition and SOL) via the geometry shader; actual 
> programmable geometry shader code is handled by brw_vec4_gs.[ch].
> With the advent of SIMD8 geometry shaders, "vec4_gs" will be confusing.  "gs" 
> is nicer.  Most of the legacy code uses the "ff_gs" name already - when Paul 
> respun his GS series, he renamed everything, but didn't change the filenames.
> Objections?  Acks?
> The "i965-reorg" branch of my tree (~kwg/mesa) has two patches to do the 
> renames:
>     i965: Rename brw_vec4_gs.[ch] to brw_gs.[ch].
>     i965: Rename brw_gs{,_emit}.[ch] to brw_ff_gs{,_emit}.[ch].
> Since they're purely "git mv" and #include fixes, I figured mailing out the 
> diff would be useless.

I think this is a good idea. I remember being a big confused by the file
names while I was working on geometry shaders. the new names looks
better to me.


More information about the mesa-dev mailing list