[Mesa-dev] Naming conventions, DSA, and meta
eric at anholt.net
Mon Feb 2 11:22:44 PST 2015
Jason Ekstrand <jason at jlekstrand.net> writes:
> Hi all,
> I wanted to send out a quick message about naming conventions for mesa
> entrypoints and dd table fallbacks. There has been some confusion and
> disagreement about this with some of the stuff Laura has been doing to
> implement DSA. Instead of side-track one of those patches for this
> discussion, I thought it was worth its own e-mail.
> When Laura started working on DSA, I suggested that, since we're
> refactoring everything anyway, we refactor the guts of the entrypoint into
> a DSA-style "internal entrypoint". This internal entrypoint takes a
> gl_context pointer, does less error checking, and actual mesa object
> pointers instead of GLuint names. I'll get to why in a minute here.
> However, that leaves us needing a naming convention for three things:
> 1) The entrypoint itself (currently _mesa_EntryPoint)
> 2) the internal entrypoint (Laura chose _mesa_entry_point)
> 3) the software fallback for the DD table entry (Laura chose
These all sound good to me.
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 818 bytes
Desc: not available
More information about the mesa-dev