[Mesa-dev] Naming conventions, DSA, and meta

Brian Paul brianp at vmware.com
Mon Feb 2 11:37:59 PST 2015

On 02/02/2015 12:22 PM, Eric Anholt wrote:
> Jason Ekstrand <jason at jlekstrand.net> writes:
>> Hi all,
>> I wanted to send out a quick message about naming conventions for mesa
>> entrypoints and dd table fallbacks.  There has been some confusion and
>> disagreement about this with some of the stuff Laura has been doing to
>> implement DSA.  Instead of side-track one of those patches for this
>> discussion, I thought it was worth its own e-mail.
>> When Laura started working on DSA, I suggested that, since we're
>> refactoring everything anyway, we refactor the guts of the entrypoint into
>> a DSA-style "internal entrypoint".  This internal entrypoint takes a
>> gl_context pointer, does less error checking, and actual mesa object
>> pointers instead of GLuint names.  I'll get to why in a minute here.
>> However, that leaves us needing a naming convention for three things:
>>   1) The entrypoint itself (currently _mesa_EntryPoint)
>>   2) the internal entrypoint (Laura chose _mesa_entry_point)
>>   3) the software fallback for the DD table entry (Laura chose
>> _mesa_TableEntry_sw)
> These all sound good to me.

Me too.


More information about the mesa-dev mailing list