[Mesa-dev] [PATCH 06/40] i965/blorp/gen7: Prepare re-using for gen8
Kenneth Graunke
kenneth at whitecape.org
Mon Apr 18 05:33:35 UTC 2016
On Saturday, April 16, 2016 4:42:34 PM PDT Topi Pohjolainen wrote:
> Signed-off-by: Topi Pohjolainen <topi.pohjolainen at intel.com>
> ---
> src/mesa/drivers/dri/i965/gen7_blorp.cpp | 6 ++++--
> 1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/src/mesa/drivers/dri/i965/gen7_blorp.cpp b/src/mesa/drivers/
dri/i965/gen7_blorp.cpp
> index eae1e30..4debeb3 100644
> --- a/src/mesa/drivers/dri/i965/gen7_blorp.cpp
> +++ b/src/mesa/drivers/dri/i965/gen7_blorp.cpp
> @@ -47,7 +47,9 @@
> static void
> gen7_blorp_emit_urb_config(struct brw_context *brw)
> {
> - unsigned urb_size = (brw->is_haswell && brw->gt == 3) ? 32 : 16;
> + const unsigned urb_size =
> + (brw->gen >= 8 || (brw->is_haswell && brw->gt == 3)) ? 32 : 16;
> +
While you're here, could you rename "urb_size" to "push_constant_kB" or
"push_size_kB"? urb_size is a really bad name, given that it's actually
the maximum size of the push constant buffer.
(It might make sense to do it as a separate patch...your call. We could
even do it after your series...)
> gen7_emit_push_constant_state(brw,
> urb_size / 2 /* vs_size */,
> 0 /* hs_size */,
> @@ -348,7 +350,7 @@ gen7_blorp_emit_gs_disable(struct brw_context *brw)
> * whole fixed function pipeline" means to emit a PIPE_CONTROL with the
"CS
> * Stall" bit set.
> */
> - if (!brw->is_haswell && brw->gt == 2 && brw->gs.enabled)
> + if (brw->gen < 8 && !brw->is_haswell && brw->gt == 2 && brw->gs.enabled)
> gen7_emit_cs_stall_flush(brw);
>
> BEGIN_BATCH(7);
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: This is a digitally signed message part.
URL: <https://lists.freedesktop.org/archives/mesa-dev/attachments/20160417/f90b4d24/attachment.sig>
More information about the mesa-dev
mailing list