[Mesa-dev] GBM and the Device Memory Allocator Proposals

Rob Clark robdclark at gmail.com
Thu Nov 30 18:52:55 UTC 2017

On Thu, Nov 30, 2017 at 4:21 AM, Nicolai Hähnle <nhaehnle at gmail.com> wrote:
> On 30.11.2017 01:09, Miguel Angel Vico wrote:
>>>> It seems to me that $new_thing should grow as a separate thing whether
>>>> it ends up replacing GBM or GBM internals are somewhat rewritten on top
>>>> of it. If I'm reading you both correctly, you agree with that, so in
>>>> order to move forward, should we go ahead and create a project in fd.o?
>>>> Before filing the new project request though, we should find an
>>>> appropriate name for $new_thing. Creativity isn't one of my strengths,
>>>> but I'll go ahead and start the bikeshedding with "Generic Device
>>>> Memory Allocator" or "Generic Device Memory Manager".
>>> liballoc - Generic Device Memory Allocator ... seems reasonable to me..
>> Cool. If there aren't better suggestions, we can go with that. We
>> should also namespace all APIs and structures. Is 'galloc' distinctive
>> enough to be used as namespace? Being an 'r' away from gralloc maybe
>> it's a bit confusing?
> libgalloc with a galloc prefix seems fine.

I keep reading "galloc" as "gralloc".. I suspect that will be
confusing.  Maybe libgal/gal_.. or just liballoc/al_?



More information about the mesa-dev mailing list