[Mesa-dev] [PATCH v2 1/8] egl: add dri2_egl_surface_free_outdated_buffers_and_update_size() helper (v2)
elongbug at gmail.com
Mon Oct 23 20:22:30 UTC 2017
Hi Emil and Gurchetan,
Thank you for reviewing the patches.
2017-10-20 6:18 GMT+09:00 Gurchetan Singh <gurchetansingh at chromium.org>:
> De-duplicating and then trimming down works for me.
> On Thu, Oct 19, 2017 at 3:31 AM, Emil Velikov <emil.l.velikov at gmail.com>
>> On 18 October 2017 at 23:36, Gurchetan Singh
>> <gurchetansingh at chromium.org> wrote:
>> >> Then again, I'd suggest keeping that as separate series. These patches
>> >> started as a way to minimise the duplication we have in drivers/dri2.
>> > I'm fine with dri2_$action_$object. We can modify the existing
>> > functions
>> > later, but I recommend adopting more concise conventions in this
>> > patchset,
>> > i.e:
>> > dri2_egl_surface_record_buffers_and_update_back_buffer -->
>> > dri2_set_back_buffer_surface
>> > dri2_egl_surface_free_outdated_buffers_and_update_size -->
>> > dri2_fixup_surface
>> > dri2_egl_surface_update_buffer_age --> dri2_update_age_surface
>> > dri2_egl_surface_get_image_front --> dri2_get_front_image_surface
>> Sure thing, let's use consistent names with this series.
It seems great with your suggested helper function names.
nevertheless, egl/driver/dri3/ codes also use such as
dri2_surface_$action_$object naming conventions.
__DRIdrawable *dri2_surface_get_dri_drawable(_EGLSurface *surf)
void dri2_surface_set_out_fence_fd(_EGLSurface *surf, int fence_fd)
If you are fine with dri2_surface_$action_$object naming convention, I
suggest these function prototype.
These have dri2_surface_$action_$object naming convention and change
type of first argument.
(struct dri2_egl_surface => _EGLSurface )
dri2_egl_surface *dri2_surf, void *buffer)
=> void dri2_surface_set_back_buffer(_EGLSurface *surf, void *buffer)
dri2_egl_surface *dri2_surf, int width, int height)
=> void dri2_surface_fixup(_EGLSurface *surf, int width, int height)
void dri2_egl_surface_update_buffer_age(struct dri2_egl_surface *dri2_surf)
=> void dri2_surface_update_age(_EGLSurface *surf)
int dri2_egl_surface_get_image_front(struct dri2_egl_surface
*dri2_surf, unsigned int format)
=> int dri2_surface_get_front_image(_EGLSurface *surf, unsigned int format)
What do you think about this?
More information about the mesa-dev