Moving code around, post classic

Jason Ekstrand jason at
Thu Dec 9 19:18:43 UTC 2021

On Thu, Dec 9, 2021 at 11:24 AM Timur Kristóf <timur.kristof at>

> On Tue, 2021-12-07 at 08:19 -0500, Alyssa Rosenzweig wrote
> >
> > If it were just linked lists, I'd say someone should write the
> > Coccinelle to transform the tree to use the one in util and call it a
> > day. It's a bit more complicated though, NIR depends on GLSL types.
> > Though that could probably continue to live in its current location
> > even
> > if glsl moves? Might breed confusion.
> These GLSL types seem to be used by a lot more than just GLSL. To avoid
> some of the confusion, why not rename them to something like NIR types,
> or something along these lines?

First off, they're already in src/compiler, not src/compiler/glsl.

Could/should we rename them?  I'm fine with that and, honestly, the only
reason I haven't yet is because it's a pile of work and because I've not
been able to come up with a better name than `glsl_type` that sounds
generic to all compiler things.  We could go `nir_type`, I guess but that's
already kind-of taken by NIR ALU types.  Then again, those could be renamed
too.  I'm kind-of meh on it.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the mesa-dev mailing list