MM compile Fails: error: unknown type name 'GTestDBus'

Michael Larson mlarson at
Thu Apr 16 17:56:02 PDT 2015

I ran into the same problem, my notes say I installed these debian 7 packages:

libglibmm-2.4-1c2a libglibmm-2.4-dev
libgudev-1.0-dev libgudev-1.0-0
libqmi-glib-dev libqmi-glib0

I also added --disable-gtk-doc to the configure statement, and did not disable qmi (some of those packages are for qmi).  I think what you need is in glib.  Maybe the versions are off by now, this was 6 months ago.  if you don’t mind, let me know what you find so I can update my notes.


Michael Larson
Western Integrated Technologies, Inc.
8900 North Ramsey Blvd.
Portland, OR 97203
Desk: 503-737-3618   Office Fax: 503-228-7318<>

Partnering with leading edge companies to make systems stronger, faster, smarter and more energy efficient.
[cid:image001.png at 01D0786E.9A3EFFA0]
Bellevue, WA | Boise, ID | Kent, WA | Los Angeles, CA | Pasco, WA | Portland, OR |Sacramento, CA | Salt Lake City, UT | Westminster, CO

From: ModemManager-devel [mailto:modemmanager-devel-bounces at] On Behalf Of Ali Nematollahi
Sent: Thursday, April 16, 2015 5:45 PM
To: modemmanager-devel at
Subject: MM compile Fails: error: unknown type name 'GTestDBus'


I am using Debian Wheezy 7.5 on an embedded target. I'm trying to install ModemManager on it. I tried apt-get and it installed a very old version. Version which does not have a support for Cinterion modems.
I've got the 1.4.6 source and I'm trying to build it on the actual target. It works well all through to compiling the plugins (which is what i actually really want!!) and it fails with the following

make[3]: Leaving directory `/root/ModemManager-1.4.6/src/tests'
make[2]: Leaving directory `/root/ModemManager-1.4.6/src'
Making all in plugins
make[2]: Entering directory `/root/ModemManager-1.4.6/plugins'
  CC     tests/libmm_test_common_la-test-fixture.lo
In file included from tests/test-fixture.c:16:0:
tests/test-fixture.h:30:5: error: unknown type name 'GTestDBus'
tests/test-fixture.c: In function 'test_fixture_setup':
tests/test-fixture.c:25:5: warning: implicit declaration of function 'g_test_dbus_new' [-Wimplicit-function-declaration]
tests/test-fixture.c:25:38: error: 'G_TEST_DBUS_NONE' undeclared (first use in this function)
tests/test-fixture.c:25:38: note: each undeclared identifier is reported only once for each function it appears in
tests/test-fixture.c:30:5: warning: implicit declaration of function 'g_test_dbus_add_service_dir' [-Wimplicit-function-declaration]
tests/test-fixture.c:33:5: warning: implicit declaration of function 'g_test_dbus_up' [-Wimplicit-function-declaration]
tests/test-fixture.c: In function 'test_fixture_teardown':
tests/test-fixture.c:77:5: warning: implicit declaration of function 'g_test_dbus_down' [-Wimplicit-function-declaration]
make[2]: *** [tests/libmm_test_common_la-test-fixture.lo] Error 1
make[2]: Leaving directory `/root/ModemManager-1.4.6/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/ModemManager-1.4.6'
make: *** [all] Error 2

I have googled this issue but I can't find any help on this. Am I missing something?

I use the following ./configure:

./configure --without-mbim --without-qmi

Any help is greatly appreciated,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 4188 bytes
Desc: image001.png
URL: <>

More information about the ModemManager-devel mailing list