FCC authentication with QMI over MBIM; try 1

Bjørn Mork bjorn at mork.no
Sun Jun 12 18:19:49 UTC 2016

Aleksander Morgado <aleksander at aleksander.es> writes:

> On Sat, Jun 11, 2016 at 11:14 AM, Stefan Armbruster
> <ml001 at armbruster-it.de> wrote:
>> @Aleksander: see the modem-manager debug logfile at
>> http://pastebin.com/4eyg9ZKk - please let me know if that is
>> sufficient or if you need something else.
> Wow, I'm impressed even myself; that looks like it worked perfectly.
> Trying to get online failed, then FCC auth run via QMI-over MBIM, then
> getting online worked.
> Still, this won't cover the cases we've seen where the modem does get
> online correctly and even gets IP once connected... Are we sure this
> latter case is related to the FCC auth command or some other issue?
> Bjørn, have you tested the EM7455 in MBIM mode?

Assume you meant MC7455, since I don't have any EM7455.  But that should
be about the same.  Attached a debug log from a short MBIM session,
using all the latest "qmi-over-mbim" branches:

 mm:      41708c4681b3 broadband-modem-mbim: try to use FCC Auth through QMI-over-MBIM if power up fails
 libmbim: d36c3c7f0bd8 build: bump version to 1.13.1
 libqmi: 2372f0405a66 build: bump version to 1.15.1

OK, that's not the latest libqmi commit.  I was too lazy to rebuild just
for a build fix ;)

Don't know if this is too useful.  I don't have FCC Auth enabled, and we
know that the commands are supported on the MC7455.  Anyway, the log is
here.  Only interesting piece is the NMEA noise which I still don't know
how to hide from MM.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug.txt.xz
Type: application/x-xz
Size: 13044 bytes
Desc: not available
URL: <https://lists.freedesktop.org/archives/modemmanager-devel/attachments/20160612/d56630b8/attachment.xz>

More information about the ModemManager-devel mailing list