Huawei ME906s does not connect

Philipp Hagemeister phihag at
Wed Jun 29 21:26:46 UTC 2016

On 29.06.2016 22:33, Andreas Fett wrote:
> On Wed, Jun 29, 2016 at 10:01:42PM +0200, Philipp Hagemeister wrote:
>> Just to be certain, I have most definitly attempted a connection here
>> (after /sys/bus/usb/devices/1-5/bConfigurationValue = 3, i.e. MBIM):
> As Bjørn said, the trick is to unconditionally switch first to 0, wait
> a little while (3 sec worked for us) and then switch back to 3. This
> leads to some kind of internal modem reset after which a connect via
> mbim works fine.

That's what I did. I waited about 10s (and later 3s) and tried multiple
times. :(

> To get actual traffic through the ndp_to_end setting is needed, too.
> For us this works for the me906s in various models of the
> skylake based ThinkPad series.
That's already Y for me:

$ cat

Should I set it to N and then later Y as well?

> This was tested however only with kernel versions 4.4 upwards
> (for which it all seemed to work).
I'm on 4.7.0-rc4-amd64 at the moment.

Is there any other tricks you've found out? In the old posts, I see you
rebooted your machine a lot. Is that still needed?



-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the ModemManager-devel mailing list