modemmanager-openwrt on UniElec U7621-06 with Sierra MC7430

salcedo-gomes.mickael at salcedo-gomes.mickael at
Thu May 24 15:49:17 UTC 2018

Hello everyone, 

I've recently purchased an UnieElec U7621-06 router with a Sierra
Wireless MC7430 modem. 

I've tried in the first place to install a ROOter firmware (snapshot
provided by ROOter team), but I've found myself facing errors which I
couldn't resolve (for whose interested [1]).
Same result, with a new build that I've made with an up-to-date OpenWRT

I've hopefully tried once more, but this time building with
modemmanager-openwrt feed instead of ROOter.
But unfortunately, I still don't succeed to correctly use my modem. 

This is a startup log :
Sun May 20 20:17:49 2018 [1560]: <info>  [device
/sys/devices/platform/1e1c0000.xhci/usb1/1-2] creating modem with plugin
'Sierra' and '4' ports
Sun May 20 20:17:49 2018 daemon.warn [1560]: <warn>  Could not grab port
(tty/ttyUSB1): 'Cannot add port 'tty/ttyUSB1', unhandled serial type'
Sun May 20 20:17:49 2018 [1560]: <info>  Modem for device
'/sys/devices/platform/1e1c0000.xhci/usb1/1-2' successfully created
Sun May 20 20:17:50 2018 daemon.warn [1560]: <warn>  Modem couldn't be
initialized: Couldn't check unlock status: SIM not inserted
Sun May 20 20:17:50 2018 [1560]: <info>  Modem: state
changed (unknown -> failed) 

And more info with mmcli commands : 

root at OpenWrt:~# mmcli -L
Found 1 modems:
    /org/freedesktop/ModemManager1/Modem/0 [Sierra Wireless,
Incorporated] MC7430

root at OpenWrt:~# mmcli -m 0
/org/freedesktop/ModemManager1/Modem/0 (device id
  Hardware |   manufacturer: 'Sierra Wireless, Incorporated'
           |          model: 'MC7430'
           |       revision: 'SWI9X30C_02.29.05.00 r7716 CARMD-EV-FRMWR2
2018/04/25 20:24:47'
           |   H/W revision: 'unknown'
           |      supported: 'gsm-umts'
           |        current: 'gsm-umts'
           |   equipment id: '359074060516194'
  System   |         device:
           |        drivers: 'cdc_mbim, qcserial'
           |         plugin: 'Sierra'
           |   primary port: 'ttyUSB2'
           |          ports: 'ttyUSB0 (qcdm), ttyUSB2 (at), wwan0 (net)'
  Numbers  |           own : 'unknown'
  Status   |           lock: 'unknown'
           | unlock retries: 'unknown'
           |          state: 'failed'
           |  failed reason: 'sim-missing'
           |    power state: 'on'
           |    access tech: 'unknown'
           | signal quality: '0' (cached)
  Modes    |      supported: 'allowed: 3g, 4g; preferred: none'
           |        current: 'allowed: any; preferred: none'
  Bands    |      supported: 'unknown'
           |        current: 'unknown'
  IP       |      supported: 'ipv4, ipv6, ipv4v6'
  SIM      |           path: 'none'
  Bearers  |          paths: 'none'

As I was quite astonished with the "Sim missing" error, I've tried to
use my MC7430 modem with an external WWAN to USB Adapter Card on a
Windows laptop with Sierra "Skylight Connection Manager" software, and
I've the same "SIM NOT INSERTED" error.

And under Ubuntu 18.04 with ModemManager, still "SIM MISSING" error. 

Am I right to believe that I have an issue with my MC7430 ?

But awkwardly, the modem responds to common AT commands and I've even
updated it to a newer firmware without problem...
How can I check that I've indeed a problem ? With a specific mmcli or AT
command for example ?
Is it possible to activate a debug mode and check modem error log ? 

Thanks a lot for your help ! 


I use Lilo, the search engine which finances social and environmental projects and its mail which reduce my environmental impact.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ModemManager-devel mailing list