[SOLVED] Quectel EC21, Debian Jessie, kernel 4.4 (patched)

Aleksander Morgado aleksander at aleksander.es
Thu Sep 6 08:13:13 UTC 2018

On Wed, Sep 5, 2018 at 2:28 PM, Brendan Simon (eTRIX)
<brendan.simon at etrix.com.au> wrote:
>> Date: Fri, 31 Aug 2018 11:28:47 +0200
>> From: Aleksander Morgado <aleksander at aleksander.es>
>> Subject: Re: Quectel EC21, Debian Jessie, kernel 4.4 (patched)
>> On Fri, Aug 31, 2018 at 9:24 AM, Brendan Simon (SEPL)
>> <brendan at successful.com.au> wrote:
>>> After the patches were applied, the device is recognise on the USB bus
>>> and
>>> MM also recongises the modem.  However I'm getting a failed status of SIM
>>> not found ("sim-missing"), but the SIM is present the dev-kit is known to
>>> work using a Windows box (i.e. gets an IP address from the 4G service).
>>> In linux, after power up, MM shows the "sim-missing" failure reason.
>> I believe that is just because you're using an ancient modemmanager
>> version, and the new "UIM" support isn't implemented in MM 1.4.0.
>> Could you update to MM 1.8? It will be totally compatible API-wise.
>>> Interestingly, after I press the reset button on the dev-kit, MM
>>> recognises
>>> a new modem and shows a "registered" status.
>>> I system now recognises the modem (/dev/cdc-wdm0 is registered as well as
>>> some /dev/ttyUSB* devices).
>>> However, nmcli shows the device as a ttyUSB instead of cdc-wdm0 !!
>>> Looking
>>> at mmcli outupt, it seems the "primary port" changes from "cdc-wdm0" to
>>> "ttyUSB8".
>>> Is this normal?  Can I force it to only use cdc-wdm?
>> That may be because the QMI port isn't responding timely after the
>> reset. Again, I believe this would be solved with newer MM/libqmi.
>>> Why does the SIM get recognised after pressing the reset button and using
>>> the ttyUSB interface, and not recongised after powerup and using the
>>> cdc-wdm0 interface?
>>> I also tried connecting the dev-kit to a Debian 9 VM, but I couldn't get
>>> MM
>>> to recognise it at all.  The ttyUSB and cdc-wdm0 interfaces were present,
>>> but "mmcli -L" shows nothing ("No modems found")
>>> Could this be related or is it a different problem altogether?
>>> How can I get MM to recognise the modem in the Debian 9 setup?
>>> linux kernel     4.9.65-3
>>> modemmanager     1.6.4-1
>>> network-manager  1.6.2-3
>> This may also be due to timing in the QMI port when it boots, maybe
>> we're not waiting enough. I'd suggest you try with the latest MM 1.8
>> if possible.
> I couldn't get the modem to attach to my VirtualBox system, so I ditched
> that (will try a Live CD at some point).  Instead I created Debian 9
> (Stretch) and Debian 10 (Buster) root filesystems for my embedded device.
> Debian 10 (Buster) worked ok and I could get a connection to the Internet :)
> It uses modemmanager 1.7.990 (if that's a real version number?  I assume
> it's 1.8 or near enough) and network-manager 1.12.2
> Debian 9 (Stretch) gave the same symptoms as Debian 8 (Jessie). Debian 9
> uses modemmanager 1.6.4 and Debian 8 uses 1.4.0.
> So my problem is solved if I want to migrate to Debian 10 (Buster), which is
> still in development (due for release early/mid 2019), or unless I can get a
> backport to Debian 9 (Stretch).

1.7.990 was 1.8-rc1, so yes, very close to 1.8.0. You can just use
1.8.0 and it will also work.


More information about the ModemManager-devel mailing list