Need help troubleshooting Quectel EG25 modem in Pine64 Pinephone

Scott Lemon slemon at
Tue Jun 1 16:05:47 UTC 2021


I'm learning Modem Manager, but looking at the output that you provided it
appears that the modem is registered on Vodafone (current), not DT.

*$ mmcli -m 0 --3gpp-scan --timeout=120*
*  ---------------------*
*  3GPP scan | networks: 26203 - o2 - de (lte, forbidden)*
*            |           26202 - Vodafone (lte, current)*
*            |           26201 - TDG (lte, available)*

You might have to issue a command to push the modem to DT?

--3gpp-register-in-operator=MCCMNC ??

Are you certain the IMSI is not providing access/roaming to Vodafone?

Scott C. Lemon
Principal IoT Solutions Engineer


Mobile: +1 (801) 336-4476
Email:   slemon at

On Mon, May 31, 2021 at 3:21 AM Andreas Hartmann <hartan at> wrote:

> Hello,
> I'm looking for guidance diagnosing what is wrong with the Quectel EG25
> modem in my PinePhone. I am aware that the modem works for pretty much
> all people, however there seem to be some exceptions to this, including
> me. I have tried several Operating Systems (Manjaro, postmarket OS,
> Fedora, mobian) but with none of these I had any success so far.
> Currently I'm tempted to believe that the hardware in my phone isn't
> entirely functional, but I wanted to make sure of that before randomly
> replacing parts.
> The issue I see is that the modem is recognized by the OS, and I can
> communicate with it through ModemManager, too. But it cannot connect to
> my carrier. I can neither make phone calls, nor receive SMS or setup a
> mobile data connection. However, the modem clearly shows that is has a
> signal reception, and I can confirm that a signal is present from
> another Android phone. I have suspected the SIM card, but when I insert
> it into an Android device it works just fine. Just to make sure I have
> even removed the SIM PIN, but that hasn't changed the situation (apart
> from some added convenience for me). I live in Germany, and the SIM is
> registered with "Deutsche Telekom".
> I can confirm that a 3GPP scan yields useful results:
> ```
> $ mmcli -m 0 --3gpp-scan --timeout=120
>   ---------------------
>   3GPP scan | networks: 26203 - o2 - de (lte, forbidden)
>             |           26202 - Vodafone (lte, current)
>             |           26201 - TDG (lte, available)
> ```
> As my operator is "Deutsche Telekom", the correct MCC/MNC is 26201, but
> mmcli shows that modem attempts to register with 26202. I seemingly
> cannot override this:
> ```
> $ mmcli -m 0 --simple-connect="apn=internet.t-mobile,user=t-
> mobile,password=tm" --timeout=120
> error: couldn't connect the modem:
> 'GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.Networ
> kTimeout: Network timeout'
> ```
> I attempted to define an initial bearer with `mmcli -m 0 --3gpp-set-
> initial-eps-bearer-settings`, but that didn't change the situation.
> The simple-connect doesn't work either, even if I explicitly specify
> the operator ID to use.
> Interestingly the behavior is pretty consistent. It happened to me with
> the stock firmware that the Pinephone Modem (Manjaro edition) shipped
> with in December/2020, it persisted after I had updated to the most
> recent modem firmware available February/2021, and it's still there
> after flashing biktorgjs custom firmware [1].
> I have tried to use various APN settings, including:
> 1. The one mentioned in the Pine64 wiki [2]
> 2. APN "internet.telekom", which is available on my Android device
> 3. APN "", which my Android device actually uses
> I don't know whether this is relevant, but the SIM is part of a
> multisim contract (Same phone number, same data plan for all SIMs).
> Curiously, recently I could accept a phone call on the Pinephone and
> talk to the other person. However this was a unique event and I
> couldn't reproduce it ever since. I can neither make calls, nor use
> mobile data.
> I'm running out of ideas as to what may cause such a behavior. I'd be
> thankful for any hints on what else to try, or possibly a diagnosis on
> whether the Modem is actually broken... Thank you in advance!
> Cheers,
> Andreas Hartmann
> [1]:
> [2]:
> _______________________________________________
> ModemManager-devel mailing list
> ModemManager-devel at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ModemManager-devel mailing list