[Nouveau] [PATCH v2 00/14] Secure Boot refactoring

Alexandre Courbot acourbot at nvidia.com
Thu Oct 27 08:27:31 UTC 2016

On 10/27/2016 01:36 PM, Alexandre Courbot wrote:
> This is a rework of the secure boot code that moves the building of the blob
> into its own set of source files (and own hooks), making the code more flexible
> and (hopefully) easier to understand as well.
> This rework is needed to support more signed firmware for existing and new
> chips. Since the firmwares in question are not available yet I cannot send the
> code to manage then, but hopefully the gain in clarity will be enough to merge
> this series ahead of the rest.
> Of the whole series, patch 8 is the most significant as it reorganizes the code
> into more source files. Chip support is separated from the ACR implementation,
> with ACR being numbered according to the (public) NVIDIA driver version it was
> build aainst. This means one can make any chip work with any ACR version just by
> instanciating the proper ACR and adds a lot of flexibility that will be required
> as more firmwares get released. At the moment, released firmwares cover driver
> versions 352 (for GM20B) and 361 (for GM200, GM204, GM206 and GP100). The r361
> implementation re-uses most of r352, and only implements its own BL descritors
> since the structure changed between the two versions.
> Other patches are a mix of minor optimizations (1, 2, 3, 4, 9, 10, 12, 13),
> small fixes (5, 7, 11), and addition of abstractions to properly support various
> ACR versions (6, 14). Not all the abstractions are used at the moment
> (particularly those of patch 14), but hopefully they will be put to good use
> soon!
> Changes since v1:
> - Use NVIDIA driver versions to differenciate the ACR structures instead of
>   arbitrary numbers
> - Add abstractions to firmware loading functions
> - Optimized set of abstractions
> - Removed some more code

Realized the naming of some structures/functions is rather off.
nvkm_acr_r352* and nvkm_acr_r361* should rather be named acr_r352* and
acr_361* to match the naming habits of Nouveau. I have fixed that in my
tree, waiting for more comments before sending v3...

More information about the Nouveau mailing list