[openchrome-devel] [Bug 106392] blank screen on OpenChrome with VIA VE900

bugzilla-daemon at freedesktop.org bugzilla-daemon at freedesktop.org
Sat Jun 16 23:22:47 UTC 2018


--- Comment #54 from ptouchman at gmail.com ---
I tried some more fiddling and was able to get a display on my Sansui SLED2900
that has no EDID on the VGA-1 (for whatever reason, I've tried a whole bunch of
different cables.)

I was able to get the Sansui to work with this workaround:

I boot debian 9.3 with these additional grub command line parameters:

drm_kms_helper.firmware_edid=edid/1280x1024.bin video=1280x1024e

and it acts differently than expected, but it tries to do mode 1152x864 (why
1152x864 I don't know)

I get a blank screen with "Not supported" on the Sansui.

I go to a text terminal with CTRL+ALT+1, login and try:

"xrandr -d :0" and it gives me some "Invalid MIT-Magic-cookie" message.

I stop the lightdm with "sudo services lightdm stop" which kills the xserver.

Then I do a startx from the command line.

I switch to a text terminal with CTRL+ALT+2, login and try:

"xrandr -d :0" and now I have access to the x server and it tells me the valid
modes available, 1360x768 is the native resolution of my Sansui.

"xrandr -d :0 --output VGA-1 --mode 1360x768" gives me the message 

Xrandr: Configure crtc 0 failed


"chvt 1; sleep 2; xrandr -d :0 --output VGA-1 --mode 1360x768"

works and I get a visible display on my Sansui.  Yes!

I'm going to post the xorg log.

You are receiving this mail because:
You are on the CC list for the bug.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.freedesktop.org/archives/openchrome-devel/attachments/20180616/24beff0a/attachment.html>

More information about the openchrome-devel mailing list