[Openicc] New OPENICC_automatic_generated metadata key

Kai-Uwe Behrmann ku.b at gmx.de
Mon Jun 20 21:42:37 PDT 2011

Am 20.06.2011 10:14, schrieb Richard Hughes:
> On 20 June 2011 06:53, Kai-Uwe Behrmann <ku.b at gmx.de> wrote:
>> The "OPENICC_automatic_generated" key follows slightly your
>> "automatic_assignment" key, which you talked about at LGM. I just added
>> q OPENICC_ prefix and created a similar name to reflect, what I found
>> more appropriate for fallback profiles. But I am neither satisfied nor
>> is it much discussed or set in stone.
> Well, I would prefer you didn't use the OPENICC_ prefix -- at least
> not without general agreement from this mailing list. Adding any
> "openicc" prefix to essentially a new Oyranos-specific key seems
> disingenuous at best.

Agreed if its not shared, it can obtain a different namespace. This
sounds already like the end of brainstorming.

>> The "edid" value is specific for a device class. As a general concept it
>> applies to ranking.
> That's a CMF implementation detail, not a property of the profile.
> colord doesn't do ranking, it just puts the edid profile in the "soft"
> profiles list and manually created profiles in the "hard" list. I
> think a COLORD_relation=soft key would be pretty insane.

"soft" is not ranked after "hard", its just put in an other list. Hmm

>> My above key tried to generalise the "edid" value
>> for all device classes. I can not get much meaning out of a "calib"
> Meaning, created using manual calibration using a hardware calibration device.

For profiles profilers get used. So a "calib" value is pretty ambiguous.
Would the calibrator for any display profile on Linux be VCGT or maybe Xorg?

>> value for a ICC profile in DATA_source. As well DATA is not easy for a
>> namespace. It is not clear wo whom it belongs and to what it applies.
> Where the data came from that allowed us to generate the profile.

I refered to DATA_ being not bound to any standard or something. EDID_
is clearly referring to a standard. But you might have not intended to
use a namespace here.

>> How about(?)
>> OPENICC_profile_source:["device","computer","internet_db"]
> Again, that's an implementation detail. You're having to do the
> heuristic OPENICC_profile_source=device for printer devices is worse
> than OPENICC_profile_source=internet_db. Broken.

np. I can rename that to an other prefix as well.

>> As only you decided to work on a CMF, the CMF_ class of key words are
>> not easy to support I guess ;-)
> Sure they are. Your CMS is lcms2 in oyranos (or sometimes lcms) and
> your CMF is "oyranos".

lcms puts its signature into the profile header already, because it is
the profile generator.

The following keys names would make sense to me. They are close to what
you proposed.

Kai-Uwe Behrmann
www.behrmann.name www.oyranos.org

More information about the openicc mailing list