[Piglit] Having issues while trying piglit, help?

Harsh Bora harsh at linux.vnet.ibm.com
Tue Nov 20 22:03:26 PST 2012

On 11/21/2012 12:05 AM, Chad Versace wrote:
> On 11/20/2012 12:59 AM, Harsh Bora wrote:
>> Hi,
>> I tried setting up piglit on my fedora 17 after installing the possibly required
>> dependencies, however am not sure which libraries are required for the below
>> OPENGL_* gaps. Here is what I see after running ccmake .
>>   CMAKE_BUILD_TYPE             Debug
>>   CMAKE_INSTALL_PREFIX             /usr/local
>>   GLEXT_INCLUDE_DIR                /usr/include
>>   PIGLIT_BUILD_GL_TESTS            ON
>>   PIGLIT_USE_WAFFLE                ON
> To build the GLES tests, the Fedora packages mesa-libGLES-devel and
> mesa-libEGL-devel are required. However, even if you have the packages
> installed, you must still explicitly enable the options
> PIGLIT_BUILD_GLES[12]_TESTS; their default value is OFF.

Hi Chad,

Thanks for an early reply. Installing those libraries helps. However, 
setting the env variable as suggested below did not help. BTW, I am 
building the piglit from source (.git tree) and run cmake from the 
source dir only. I am still get the same err even after setting up the 
suggested env variable. Is there anything else that I could be missing 
to generate tests (and therefore the 'spec' sub-dir there) ?


> I should probably update the README to explain that.
>> Also, when I try to run all tests, I see the below err (cant find folder 'spec'
>> in generated_tests/ sub-dir):
>> [harshpb at localhost piglit]$ ./piglit-run.py tests/all.tests results/all.results
>> Traceback (most recent call last):
>>    File "/home/harshpb/Work/git-trees/RAS/FutureWork/piglit/framework/core.py",
>> line 582, in loadTestProfile
>>      execfile(filename, ns)
>>    File "tests/all.tests", line 2609, in <module>
>>      recursive=True)
>>    File "tests/all.tests", line 193, in add_shader_test_dir
>>      for filename in os.listdir(dirpath):
>> OSError: [Errno 2] No such file or directory: 'tests/../generated_tests/spec'
>> Traceback (most recent call last):
>>    File "./piglit-run.py", line 220, in <module>
>>      main()
>>    File "./piglit-run.py", line 188, in main
>>      profile = core.loadTestProfile(profileFilename, resultsDir)
>>    File "/home/harshpb/Work/git-trees/RAS/FutureWork/piglit/framework/core.py",
>> line 585, in loadTestProfile
>>      raise Exception('Could not read tests profile')
>> Exception: Could not read tests profile
>> [harshpb at localhost piglit]$
>> Can anyone help ?
> Did you configure cmake to build out-of-tree? If so, the problem may
> be that you need to set the environment variable PIGLIT_BUILD_DIR, as
> explained in the README.

More information about the Piglit mailing list