[Piglit] Having issues while trying piglit, help?

Harsh Bora harsh at linux.vnet.ibm.com
Tue Nov 20 22:10:35 PST 2012

On 11/21/2012 11:33 AM, Harsh Bora wrote:
> On 11/21/2012 12:05 AM, Chad Versace wrote:
>> On 11/20/2012 12:59 AM, Harsh Bora wrote:
>>> Hi,
>>> I tried setting up piglit on my fedora 17 after installing the
>>> possibly required
>>> dependencies, however am not sure which libraries are required for
>>> the below
>>> OPENGL_* gaps. Here is what I see after running ccmake .
>>>   CMAKE_BUILD_TYPE             Debug
>>>   CMAKE_INSTALL_PREFIX             /usr/local
>>>   GLEXT_INCLUDE_DIR                /usr/include
>>>   OPENGL_gles1_LIBRARY             OPENGL_gles1_LIBRARY-NOTFOUND
>>>   OPENGL_gles2_LIBRARY             OPENGL_gles2_LIBRARY-NOTFOUND
>>>   PIGLIT_BUILD_CL_TESTS            OFF
>>>   PIGLIT_BUILD_GL_TESTS            ON
>>>   PIGLIT_USE_WAFFLE                ON
>> To build the GLES tests, the Fedora packages mesa-libGLES-devel and
>> mesa-libEGL-devel are required. However, even if you have the packages
>> installed, you must still explicitly enable the options
>> PIGLIT_BUILD_GLES[12]_TESTS; their default value is OFF.
> Hi Chad,
> Thanks for an early reply. Installing those libraries helps. However,
> setting the env variable as suggested below did not help. BTW, I am
> building the piglit from source (.git tree) and run cmake from the
> source dir only. I am still get the same err even after setting up the
> suggested env variable. Is there anything else that I could be missing
> to generate tests (and therefore the 'spec' sub-dir there) ?

Ok, my bad. I just missed rebuilding tests after installing those 
libraries. It appears to work fine now, thanks.


More information about the Piglit mailing list