[Piglit] Requiring Python 3.x for Piglit?
kenneth at whitecape.org
Wed Apr 17 10:32:10 PDT 2013
On 04/17/2013 07:37 AM, Brian Paul wrote:
> On 04/17/2013 03:48 AM, Kenneth Graunke wrote:
>> Does anyone object to porting to Python 3.x (and dropping 2.x support)?
>> Some useful data points:
>> - Debian stable has 3.1, testing/unstable have 3.2
>> - Fedora 18 and Arch Linux have 3.3
>> - Windows installers for 3.3 are available on python.org
>> - Mac OS X support for 3.3 is also available on python.org
>> - numpy and mako are both available for Python 3 now. numpy is
>> packaged on Arch and Debian testing/unstable. Not sure how much of a
>> pain it is to get on Windows/OSX.
>> - intel-gpu-tools now requires Python 3.x to build.
>> Jon Severinsson did a great job in making a hybrid solution that works
>> with both Python 2 and 3, but I'm a bit nervous about some of it. For
>> example, unicode stuff has bitten us in the past, and supporting only
>> one major language version seems a lot easier to get right. It'd also
>> be a lot cleaner to just transition to Python 3.x.
> We have an environment here that uses Python 2.6. I've had to hack a
> few things to make piglit work there but it's not bad. Going to Python
> 3.x might be pretty painful, but I'd have to do some research to know
> for sure, and I don't have time right now.
> Can we please hold off on this for a while?
I thought Dylan's recent patches to use argparse required 2.7 and
dropped support for 2.6...so I'm confused how your system would work.
Or, is that what you're hacking around?
More information about the Piglit