[Piglit] [PATCH 2/2] cl: Add generated tests for global and local stores

Dylan Baker baker.dylan.c at gmail.com
Thu Aug 1 19:43:49 PDT 2013


Ah, that makes sense.

I have no further complaints and I'm not sure what the most approriate tag
is, since I'm not a CL expert. I'm guessing acked-by, but feel free to use
something else if it's more appropriate.
Acked-by: Dylan Baker <baker.dylan.c at gmail.com>


On Thu, Aug 1, 2013 at 7:34 PM, Tom Stellard <tom at stellard.net> wrote:

> On Wed, Jul 31, 2013 at 11:37:16PM -0700, Dylan Baker wrote:
>
> Hi Dylan,
>
> Thanks for your comments.
>
> > I have some python comments for you, they're mainly style type comments,
> > but some of them should help your code readability a lot.
> >
> >
> > On Wed, Jul 31, 2013 at 7:16 PM, Tom Stellard <tom at stellard.net> wrote:
> >
> > > +VEC_SIZES = ['', '2', '4', '8', '16']
> > > +
>
> ...
>
> > I only see the one use of VEC_SIZES. Is there a reason element 0 is set
> to
> > '' and then you have an if statement here to change it to 1?
> >
>
> For the first element, 1 is the vector size, but '' is the string that
> needs to be appended to the type name. e.g.
>
> Type   Size
> -----  -----
> Float    1
> Float2   2
> Float4   4
>
> etc.
>
> I have addressed all you other comments in the attached patch.
>
> -Tom
>
> > +        else:
> > > +            size = int(s)
> > > +        type_name = t + s
> > > +        f = begin_test(type_name, 'global')
> > > +        f.write( \
> > > +            '[test]\n' + \
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freedesktop.org/archives/piglit/attachments/20130801/b637381e/attachment-0001.html>


More information about the Piglit mailing list