[Pm-utils] [RFC] [patch review] Hook independence and security fixups, part 1

Victor Lowther victor.lowther at gmail.com
Sat Feb 2 07:01:31 PST 2008

On Sat, 2008-02-02 at 15:38 +0100, Michael Biebl wrote:
> 2008/2/2, Michael Biebl <mbiebl at gmail.com>:
> > 2008/2/1, Victor Lowther <victor.lowther at gmail.com>:
> > > Here are a few more patches in this series that add a
> > > /usr/lib/pm-utils/config.d to go along with /etc/pm/config.d, the
> > > needed changes to make functions aware of this, some modifications to
> > > push certian generic environment variables into the new per-hook
> > > configuration scheme, and how to override a suspend/resume method to
> > > use something besides the default kernel methods without having to
> > > patch the source to pm-utils.
> > >
> > > These patches apply on top of the last set of patches, or you can just
> > > pull the (misnamed now) vlowther-security-audit branch from
> > > git://fnordovax.org/pm-utils/
> > >
> >
> > Hm, tbh I find it a bit weird, that the do_hibernate method is now in
> > a *config* file.
> > Seems a bit counter-intuitive to me.
> I.e. if you want to refactor the functions script and pull out methods
> into separate scriplets, they should be placed under a directory named
> functions.d imho. Given the current size of the functions file this
> seem a bit of overkill to me.
> This might change though, when we have tuxonice and userspace suspend
> implemented.

Well, the conditional blocks around the current 
do_(suspend|hibernate|suspend_hybrid) are my stab at making tuxonice and
userspace suspend support easy to implement without having to patch the
pm-utils core.  Since (in the end), it all comes down to calling one of
those three functions anyways, why not make them easy to override with
whatever the distro maintainer or end user want?

> Cheers,
> Michael

More information about the Pm-utils mailing list