[Pm-utils] No wake-up from suspend to RAM

Thomas Börkel thomas at boerkel.de
Sun Aug 16 04:22:41 PDT 2009


I have a ASUS M68Ne laptop. It has Intel WLAN and ATI gfx chip (using
the radeon driver). I am running Gentoo, kernel 2.6.30, KDE 4.3.

I use acpi_sleep=s3_bios as kernel parameter.

When I use the hibernate scripts to suspend to RAM ("hibernate-ram"),
the laptop suspends and wakes up without problems.

When I use "pm-suspend", it also suspends, but when I press the power
button, the power goes on, but the laptop is not usable. The screen is
dark and I cannot ssh (over WLAN) into it.

I already tried using acpi_sleep=s3_bios,s3_mode as kernel parameter and
using --quirk-s3-bios for pm-suspend. Same result.

In pm-suspend.log, there is nothing about the wake-up. Attaching the log.

Any help would be greatly appreciated. I want to use pm-utils, because
KDE4's powerdevil uses it.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pm-suspend.log
Url: http://lists.freedesktop.org/archives/pm-utils/attachments/20090816/34ce93cd/attachment.ksh 

More information about the Pm-utils mailing list