[Pm-utils] No wake-up from suspend to RAM

Victor Lowther victor.lowther at gmail.com
Mon Aug 17 18:38:52 PDT 2009

On Sun, Aug 16, 2009 at 6:22 AM, Thomas Börkel <thomas at boerkel.de> wrote:

> HI!
> I have a ASUS M68Ne laptop. It has Intel WLAN and ATI gfx chip (using
> the radeon driver). I am running Gentoo, kernel 2.6.30, KDE 4.3.
> I use acpi_sleep=s3_bios as kernel parameter.
> When I use the hibernate scripts to suspend to RAM ("hibernate-ram"),
> the laptop suspends and wakes up without problems.
> When I use "pm-suspend", it also suspends, but when I press the power
> button, the power goes on, but the laptop is not usable. The screen is
> dark and I cannot ssh (over WLAN) into it.
> I already tried using acpi_sleep=s3_bios,s3_mode as kernel parameter and
> using --quirk-s3-bios for pm-suspend. Same result.
> In pm-suspend.log, there is nothing about the wake-up. Attaching the log.
> Any help would be greatly appreciated. I want to use pm-utils, because
> KDE4's powerdevil uses it.
> Thanks!

<log snipped>

Based on that log, something bad is happening while trying to wake up in the
kernel -- what happens if you don't pass any quirks and let the auto-quirk
machinery handle getting the right quirks for your laptop?

You might also want to try suspend/resume outside X if you have not already
done so.

> Thomas
> _______________________________________________
> Pm-utils mailing list
> Pm-utils at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pm-utils
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.freedesktop.org/archives/pm-utils/attachments/20090817/ad4300d1/attachment.html 

More information about the Pm-utils mailing list