[Pm-utils] pm-hibernate on a Lenovo T431s

Tomas Davidek Tomas.Davidek at cern.ch
Tue Nov 5 15:45:54 CET 2013

    after some more tests, here is more detailed info. Unfortunately I 
did not find the solution yet. Anyway:
1. I've put the logs (pm-suspend and syslog) on my web page
Although I am not 100% sure, I think that the image is written to swap 
and the computer switches off. The problem seems to be when reading the 
image during resume, but nothing is written to the log files..... The 
system is not completely dead, I can push enter and the cursor appearing 
in top left corner moves down, but e.g. Ctrl+Alt+Del is not working....

2. I also tried with Ubuntu installed in another partition, same story.

3. my colleague, owning the same laptop, reports similar behaviour. He 
has uswsusp installed, during the resume the image is read up to 100%, 
then he gets the message:
"Resume: image successfully loaded."
and then the same blinking cursor in top left corner appears in the 
screen (same cases for me)

4. I also looked into Bios, I made sure UEFI is not used.

Can you please suggest further tests and/or point out where the problem 
might be? I tried with both kernel 3.11 and 3.10, same behaviour.

Any hint is highly appreciated.

Best regards,

On 11/01/2013 12:42 PM, Tomas Davidek wrote:
> Dear all,
>     I got a new laptop Lenovo T431s and I am fighting a lot with 
> hibernation.
> When trying simply pm-hibernate from text console, the system 
> apparently saves the image to swap and powers off. That's ok. But when 
> booting again, the last message on the screen is
> Booting the kernel.
> Loading, please wait...
> I expected more info, since I set PM_DEBUG="true" in 
> /etc/pm/config.d/01_debug.conf
> Anyway, looking in the log (/var/log/pm-suspend.log) there are 
> thousands of messages, it finishes with:
> + inhibited
> + [ -f /var/run/pm-utils/pm-suspend/storage/inhibit ]
> + return 0
> + date
> + log Fri Nov  1 12:19:11 CET 2013: performing hibernate
> + is_set true
> + return 0
> + local fmt=%s\n
> + [ Fri Nov  1 12:19:11 CET 2013: performing hibernate = -n ]
> + printf %s\n Fri Nov  1 12:19:11 CET 2013: performing hibernate
> Fri Nov  1 12:19:11 CET 2013: performing hibernate
> + sync
> + do_hibernate
> + [ -n  ]
> + echo -n disk
> Sounds like there is no message from the resume process? GRUB is set 
> with resume:swap=/dev/sda7, so this should be ok too....
> This has been obtained with purely pm-utils,  without hibernate & 
> uswsusp installed. I also tried with uswsusp installed, the behaviour 
> is similar, the resume process hangs at similar message
> resume: image successfully loaded
> Frankly speaking, I don't understand the interplay between pm-utils 
> and swsusp, I thought these are different front-ends?
> Thanks a lot for any hint in advance,
> cheers,
>                   Tomas
> _______________________________________________
> Pm-utils mailing list
> Pm-utils at lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/pm-utils

More information about the Pm-utils mailing list